Konfigurasi EVPN MPLS antara Nokia dan Juniper Part 1

Apa itu EVPN? Mungkin untuk belakangan ini kita sering mendengar kata yang satu ini, karena semakin gencarnya pengaplikasian teknologi Overlay Network. EVPN adalah teknologi yang menyediakan konektivitas virtual bridge antara layer 2 doamain yang berbeda diatas IP/MPLS. Sesungguhnya  sudah terdapat teknologi yang fungsinya sama dengan yang disebutkan diatas, yaitu VPLS yang didefinisikan di RFC 4762 dan sudah dipakai dari sekitar tahun 2007. Sampai sekarang pun semua provider di indonesia menggunakan VPLS untuk membangun jaringan bridge diatas IP/MPLS.

Namun, solusi yang ditawarkan VPLS memiliki bebrapa limitasi ketika harus diimplementasikan pada Data Center (DC) environment seperti multihoming dan redudancy, multicast optimization, provisioning simplicity, flow-based load balancing, dan multipathing.

EVPN versus VPLS

Kita akan melakukan sedikit komparasi perbedaan antara EVPN dengan VPLS, untuk ditekankan bahwa EVPN bukanlan VPLS.

Signaling Protocols
VPLS punya dua opsi signaling protocol yaitu LDP (T-LDP) dan BGP (hanya support autodiscovery). EVPN tidak menggukan T-LDP namun mengadposi BGP sebagai satu-satunya service signaling protocol.

MAC address learning
VPLS hanya mempunyai data-plane MAC learning baik pada local maupun remote, EVPN juga melakukan MAC learning data-plane, namun hanya pada local Attachment Circuit (AC), control-plane digunakan untuk learning MAC address antara PE router yaitu menggunkan BGP untuk exchange MAC address routes.

Customer Edge (CE) Multihoming
EVPN mengimplementasikan dua solusi CE multihoming yaitu single-active (satu aktif, N standby) dan all-active (dengan metode load balancing per-flow unicast), sedangkan VPLS hanya memiliki satu opsi yaitu single-active multihominng

EVPN Implementations
Ada tiga cara pengimplementasian EVPN yaitu Provider Backcbone Bridging (PBB) EVPN, EVPN dengan Transport MPLS, EVPN dengan transport VXLAN (Virtual eXtensible LAN). EVPN VXLAN diimplementasikan pada Environment Data Center (DC), sedangkan EVPN MPLS dan PBB pada environment backbone, sesungguhnya semua bisa diimplementasikan pada setiap environment tergantung pada design dan device capability.

Artikel ini akan membahas basic implementasi EVPN dengan transport MPLS antara router Nokia dan Juniper.

 

LAB GUIDE

Software yang dipakai untuk melakukan Lab simulasi ini adalah sebagai berikut :

  1. GNS3 v2.1.5
  2. TiMOS-B-15.0.R5
  3. Junos vMX 14.1R4.8

Basic Configuration
Topologi yang digunakan hanya sederhana, terdiri dari 2 PE (Provider Edge) router (PE1 Juniper/PE2 Nokia) dan 1 RR (Nokia)

Customer Edge (CE) yang diattach di kedua PE hanya menggunakan Virtual PC yang ada di GNS3 karena hanya bertujuan untuk tes koneksi (PING) direct CE1-CE2.

Saya telah melakukan basic konfigurasi pada topologi tersebut yaitu konfigurasi IP address, IGP menggunkan OSPF, MPLS/LDP dan Autonomous System Number 65000. Berikut Snapshot konfigurasinya pada setiap router (PE1, PE2, RR)

PE1

root@PE1>  show configuration 
version 14.1R4.8;
system {
    root-authentication {
        encrypted-password "$1$sggwNHgH$J/vedDDOQzYVN4YpYgZQq0"; ## SECRET-DATA
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    ge-0/0/1 {
        description to-pe2;
        unit 0 {
            family inet {
                address 172.0.1.5/30;
            }
            family mpls;
        }
    }
    ge-0/0/2 {
        unit 0 {
            description to-rr;
            family inet {
                address 114.0.17.2/30;
            }
            family mpls;
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.10.10.1/32;  
            }
        }
    }
}
routing-options {
    autonomous-system 65000;
}
protocols {
    mpls {
        interface lo0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
    }
    ospf {                              
        area 0.0.0.0 {
            interface lo0.0;
            interface ge-0/0/1.0 {
                interface-type p2p;
            }
            interface ge-0/0/2.0 {
                interface-type p2p;
            }
        }
    }
    ldp {
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface lo0.0;
    }
}
root@PE1>

PE2

A:PE2# admin display-config 

exit all
configure
#--------------------------------------------------
echo "System Configuration"
#--------------------------------------------------
    system
        name "PE2"
        time
            sntp
                shutdown
            exit
            zone UTC 
        exit
    exit
#--------------------------------------------------
echo "System Security Configuration"
#--------------------------------------------------
    system
        security
            per-peer-queuing
            dist-cpu-protection
                policy "_default-access-policy" create
                exit
                policy "_default-network-policy" create
                exit
            exit
        exit
    exit
#--------------------------------------------------
echo "Log Configuration"
#--------------------------------------------------
    log 
    exit 
#--------------------------------------------------
echo "Card Configuration"
#--------------------------------------------------
    card 1
        card-type iom-xp
        mda 1
            mda-type c5-1gb-xp-sfp
            no shutdown
        exit
        no shutdown
    exit
#--------------------------------------------------
echo "Port Configuration"
#--------------------------------------------------
    port 1/1/1
        ethernet
		    mtu 1514
        exit
        no shutdown
    exit
    port 1/1/2
        ethernet
            mtu 1514
        exit
        no shutdown
    exit
    port 1/1/3
        shutdown
        ethernet
        exit
    exit
    port 1/1/4
        shutdown
        ethernet
        exit
    exit
    port 1/1/5
        shutdown
        ethernet
        exit
    exit
#--------------------------------------------------
echo "System Sync-If-Timing Configuration"
#--------------------------------------------------
    system
        sync-if-timing
            begin
            commit
        exit
    exit
#--------------------------------------------------
echo "Management Router Configuration"
#--------------------------------------------------
    router management
    exit

#--------------------------------------------------
echo "Router (Network Side) Configuration"
#--------------------------------------------------
    router Base
        interface "system"
            address 10.10.10.2/32
            no shutdown
        exit
        interface "to-pe1"
            address 172.0.1.6/30
            port 1/1/2
            no shutdown
        exit
        interface "to-rr"
            address 114.0.16.2/30
            port 1/1/1
            no shutdown
        exit
        autonomous-system 65000
#--------------------------------------------------
echo "OSPFv2 Configuration"
#--------------------------------------------------
        ospf 0
            area 0.0.0.0
                interface "system"
                    no shutdown
                exit
                interface "to-pe1"
                    interface-type point-to-point
                    no shutdown
                exit
				interface "to-rr"
                    interface-type point-to-point
                    no shutdown
                exit
            exit
            no shutdown
        exit
#--------------------------------------------------
echo "LDP Configuration"
#--------------------------------------------------
        ldp
            interface-parameters
                interface "to-pe1" dual-stack
                    ipv4
                        no shutdown
                    exit
                    no shutdown
                exit
                interface "to-rr" dual-stack
                    ipv4
                        no shutdown
                    exit
                    no shutdown
                exit
            exit
            targeted-session
            exit
            no shutdown
        exit
    exit

exit all

A:PE2#

RR

A:RR# admin display-config 

exit all
configure
#--------------------------------------------------
echo "System Configuration"
#--------------------------------------------------
    system
        name "RR"
        time
            sntp
                shutdown
            exit
            zone UTC 
        exit
    exit
#--------------------------------------------------
echo "System Security Configuration"
#--------------------------------------------------
    system
        security
            per-peer-queuing
            dist-cpu-protection
                policy "_default-access-policy" create
                exit
                policy "_default-network-policy" create
                exit
            exit
        exit
    exit
#--------------------------------------------------
echo "Log Configuration"
#--------------------------------------------------
    log 
    exit 
#--------------------------------------------------
echo "Card Configuration"
#--------------------------------------------------
    card 1
        card-type iom-xp
        mda 1
            mda-type c5-1gb-xp-sfp
            no shutdown
        exit
        no shutdown
    exit
#--------------------------------------------------
echo "Port Configuration"
#--------------------------------------------------
    port 1/1/1
        ethernet
            mtu 1514
        exit
        no shutdown
    exit
    port 1/1/2
        ethernet
            mtu 1514
        exit
        no shutdown
    exit
    port 1/1/3
        shutdown
        ethernet
        exit
    exit
    port 1/1/4
        shutdown
        ethernet
        exit
    exit
    port 1/1/5
        shutdown
        ethernet
        exit
    exit
#--------------------------------------------------
echo "System Sync-If-Timing Configuration"
#--------------------------------------------------
    system
        sync-if-timing
            begin
            commit
        exit
    exit
#--------------------------------------------------
echo "Management Router Configuration"
#--------------------------------------------------
    router management
    exit

#--------------------------------------------------
echo "Router (Network Side) Configuration"
#--------------------------------------------------
    router Base
        interface "system"
            address 10.10.10.10/32
            no shutdown
        exit
        interface "to-pe1"
            address 114.0.17.1/30
            port 1/1/2
            no shutdown
        exit
        interface "to-pe2"
            address 114.0.16.1/30
            port 1/1/1
            no shutdown
        exit
        autonomous-system 65000
#--------------------------------------------------
echo "OSPFv2 Configuration"
#--------------------------------------------------
        ospf 0
            area 0.0.0.0
                interface "system"
                    no shutdown
                exit
                interface "to-pe2"
                    interface-type point-to-point
                    no shutdown
                exit
                interface "to-pe1"
                    interface-type point-to-point
                    no shutdown
                exit
            exit
            no shutdown
        exit
#--------------------------------------------------
echo "LDP Configuration"
#--------------------------------------------------
        ldp
            interface-parameters
                interface "to-pe2" dual-stack
                    ipv4
                        no shutdown
                    exit
                    no shutdown
                exit
                interface "to-pe1" dual-stack
                    ipv4
                        no shutdown
                    exit
                    no shutdown
                exit
            exit
            targeted-session
            exit
            no shutdown
        exit
    exit
exit all

A:RR#

BGP EVPN Address Family Configuration
BGP EVPN masuk dalam kategori Multiprotocol-BGP (MP-BGP) dengan address family AFI=25, SAFI=70. Nilai AFI dan SAFI digunakan untuk mengidentifikasi jenis route yang dibawa oleh BGP, list lengkap nilai AFI/SAFI dapat dilihat pada halaman resmi web IANA.

PE1

root@PE1> show configuration protocols bgp 
group internal {
    type internal;
    family evpn {
        signaling;
    }
    neighbor 10.10.10.10;
}

root@PE1>

PE2

A:PE2>config>router>bgp# info 
----------------------------------------------
            min-route-advertisement 1
            enable-peer-tracking
            rapid-update evpn
            group "intenal"
                family evpn
                type internal
                neighbor 10.10.10.10
                exit
            exit
            no shutdown
----------------------------------------------
A:PE2>config>router>bgp#

RR

A:RR>config>router>bgp# info 
----------------------------------------------
            min-route-advertisement 1
            enable-peer-tracking
            rapid-update evpn
            group "internal"
                family evpn
                type internal
                cluster 10.10.10.10
                neighbor 10.10.10.1
                exit
                neighbor 10.10.10.2
                exit
            exit
            no shutdown
----------------------------------------------
A:RR>config>router>bgp#

Setelah semua basic konfigurasi dilakukan maka selanjutnya membuat service VPN Layer 2 menggunakan teknologi EVPN yang akan dilakukan pada postingan Konfigurasi EVPN MPLS antara Nokia dan Juniper Part 2

 

About the author
Khoirul Firdaus

Khoirul Firdaus

Network Telco Engineer - SDN/NFV Enthusiast

Routecloud Networks

Information about Server, Linux and Computer Network.

Great! You’ve successfully signed up.

Welcome back! You've successfully signed in.

You've successfully subscribed to Routecloud Networks.

Success! Check your email for magic link to sign-in.

Success! Your billing info has been updated.

Your billing was not updated.